Virtual Box: Σφάλμα στο .VirtualBox.xml (the machine is inaccessible)

by 7:20 μ.μ. 0 σχόλια
Σε μηχάνημα φίλου, αντιμετώπισα πρόβλημα εκκίνησης εικονικού windows (το έχει για φορολογικό μηχανισμό στην δουλειά του). Το σφάλμα που έβγαζε έμοιαζε περίπου όπως το παρακάτω (δυστυχώς δεν κράτησα screenshot):

the machine is inaccessible

p, li { white-space: pre-wrap; } Start tag expected, '<' not found.
Location: '/home/brett/.VirtualBox/Machines/Work/Work.xml', line 1 (0), column 1.
/home/vbox/vbox-3.1.2/src/VBox/Main/MachineImpl.cpp[5821] (nsresult Machine::loadSettings(bool)).
Result Code:
NS_ERROR_FAILURE (0x80004005)
Component:
VirtualBox
Interface:
IVirtualBox {2158464a-f706-414b-a8c4-fb589dfc6b62}


Μετά από ελάχιστο ψάξιμο βρήκα την λύση (από αυτήν πήρα το κείμενο του σφάλματος). Βασικά το αρχείο VirtualBox.xml (στην περίπτωσή μου) ήταν άδειο. Στον ίδιο κατάλογο υπήρχε ένα άλλο αρχείο backup (πιθανό ο τεχνικός του να το έκανε backup και να μην το ολοκλήρωσε). Πήρα λοιπόν το περιεχόμενο του αρχείου backup και το επικόλλησα στο VirtualBox.xml.

Μέχρι εδώ κατάφερα να ανοίξω το VirtualBox. Στη συνέχεια έπρεπε να δω γιατί δεν ανοίγει η εικονική μηχανή που χρησιμοποιούσε. Έτσι ακολούθησα τα βήματα του forum.

1. Ξεκίνησα να δημιουργώ μια νέα μηχανή. Επειδή δεν γνώριζα τα χαρακτηριστικά της, έβαλα κάποια κάπως καλά.

2. Όταν έφτασα στο σημείο που ζητούσε να δημιουργήσω δίσκο, επέλεξα να δει από κάποιον ήδη δημιουργημένο. Επειδή είχε 3 φακέλους, επέλεξα αυτόν με την πιο πρόσφατη ημερομηνία. Επέλεξα λοιπόν το αρχείο .vdi και δημιουργήθηκε η νέα εικονική μηχανή.

Η μηχανή άνοιξε μια χαρά. Επειδή δεν γνωρίζω πως γίνεται να είναι ΜΟΝΙΜΑ συνδεδεμένοι οι εκτυπωτές, τους συνδέει χειροκίνητα από το Virtual Box.

Efstathios Iosifidis

openSUSE and GNOME foundation member

I'm Farm Animal Manager and dairy products technician looking for new opportunities.

0 σχόλια:

Δημοσίευση σχολίου